php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48145 Japanese explanation of array_intersect_key doesn't make sense
Submitted: 2009-05-04 13:53 UTC Modified: 2009-05-04 13:59 UTC
From: sekiguchi328 at yahoo dot co dot jp Assigned:
Status: Closed Package: Translation problem
PHP Version: Irrelevant OS: N/A
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sekiguchi328 at yahoo dot co dot jp
New email:
PHP Version: OS:

 

 [2009-05-04 13:53 UTC] sekiguchi328 at yahoo dot co dot jp
Description:
------------
The explanation of array_intersect_key function in the Japanese translation of the PHP reference manual, available on http://jp.php.net/manual/ja/function.array-intersect-key.php , doesn't make sense.  The English text reads: "array_intersect_key() returns an array containing all the values of array1  which have matching keys that are present in all the arguments."  Currently the Japanese text read: "array_intersect_key() ?́A???̑S?Ă̈????ɑ??݂??? array1  ?̒l???S?ėL?????z?????Ԃ??܂??B", it doesn't make any sense.  (The sentense briefly reads something like: "array_intersect_key() returns an array having all values of array1 existing in all other arguments."  Note that no mention on _keys_.

Reproduce code:
---------------
Access to http://jp.php.net/manual/ja/function.array-intersect-key.php

Expected result:
----------------
A suggested Japanese sentense is: "array_intersect_key() ?́Aarray1 ?̒l?̂????A???̑??̂??ׂĂ̈????̒??ɋ??ʂ??đ??݂????L?[?ƈ??v?????L?[?̒l?????Ȃ??z?????Ԃ??܂??B"


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-04 13:59 UTC] takagi@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.

http://news.php.net/php.doc.ja/2465
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Jun 14 22:01:30 2024 UTC