php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #48102 run-tests.php and symlinked tests
Submitted: 2009-04-28 21:45 UTC Modified: 2012-09-08 15:15 UTC
From: fa@php.net Assigned:
Status: Not a bug Package: Testing related
PHP Version: 6CVS-2009-04-28 (CVS) OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fa@php.net
New email:
PHP Version: OS:

 

 [2009-04-28 21:45 UTC] fa@php.net
Description:
------------
I was just trying out some tests written for 5.3 with HEAD, when I noticed the following:

$ make test TESTS=ext/whatever

Warning: fopen(): Filename cannot be empty in /root/src/php6/run-tests.php on line 1164
ERROR: Cannot open test file:
make: [test] Error 1 (ignored)

That means if there's a symlink with no endpoint, the whole testsuite can't run. It works fine if the symlinked file is just an empty (existing) file:

BORK cannot read test [/tmp/foo]

Yes, having tests only symlinked inside the source dir might be weird, so I filed this as feature request and not bug

Reproduce code:
---------------
$ touch /tmp/foo
$ ln -s /tmp/foo /path/to/php-src/ext/whatever/tests/foo.phpt
$ rm /tmp/foo
$ make test TESTS=ext/whatever

Expected result:
----------------
$ make test TESTS=ext/whatever
[...]
BORK symlink endpoint /tmp/foo doesn't exist

Actual result:
--------------
$ make test TESTS=ext/whatever

Warning: fopen(): Filename cannot be empty in /root/src/php6/run-tests.php on line 1164
ERROR: Cannot open test file:
make: [test] Error 1 (ignored)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-26 22:14 UTC] tyrael@php.net
-Package: Feature/Change Request +Package: Testing related
 [2012-09-08 15:15 UTC] felipe@php.net
Not a problema anymore.
 [2012-09-08 15:15 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 04:01:24 2021 UTC