php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48095 Load RDF Format Error
Submitted: 2009-04-28 03:25 UTC Modified: 2009-09-25 16:19 UTC
From: pigo_chu at hotmail dot com Assigned:
Status: Not a bug Package: *XML functions
PHP Version: 5.2.9 OS: win32 only - Windows XP SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pigo_chu at hotmail dot com
New email:
PHP Version: OS:

 

 [2009-04-28 03:25 UTC] pigo_chu at hotmail dot com
Description:
------------
The url http://www.nownews.com/rss/realtime.rdf is rdf document
Use any xml function(simplexml or domdocument) to load the url
On Linux PHP 5.2.9 is ok
On Windows XP SP3 has error

Reproduce code:
---------------
$doc = simplexml_load_file('http://www.nownews.com/rss/realtime.rdf');
var_dump($doc);



Expected result:
----------------
output is 'false'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-28 22:22 UTC] fa@php.net
The URL mentioned passes http://www.w3.org/RDF/Validator/ as of now.
5.2.9 on Linux reads it correctly,
5.2.9-2 on XP / SP3 yields this result:

PHP Warning:  simplexml_load_file(): input conversion failed due to input error, bytes 0xA1 0xFE 0xA6 0xCC in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file(): input conversion failed due to input error, bytes 0xA1 0xFE 0xA6 0xCC in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file(): encoder errorhttp://www.nownews.com/rss/realtime.rdf:79: parser error : Premature end of data in tag title line 79 in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file():     <title>&#31933;&#23376;&#25512;&#34214; in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file():                        ^ in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file(): http://www.nownews.com/rss/realtime.rdf:79: parser error : Premature end of data in tag item line 77 in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file():     <title>&#31933;&#23376;&#25512;&#34214; in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file():                        ^ in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file(): http://www.nownews.com/rss/realtime.rdf:79: parser error : Premature end of data in tag RDF line 2 in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file():     <title>&#31933;&#23376;&#25512;&#34214; in D:\code\48095.php on line 2
PHP Warning:  simplexml_load_file():                        ^ in D:\code\48095.php on line 2
 [2009-09-25 16:19 UTC] rrichards@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is caused by some problem in the libiconv library. Your Linux 
system is mostly using the glibc implementation which is why it works 
there. Not a PHP issue but a libiconv problem.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 04:05:53 2022 UTC