php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #48068 java.lang.UnsatisfiedLinkError: startup , net.php.servlet.startup(Native Method
Submitted: 2009-04-24 11:58 UTC Modified: 2009-04-24 22:13 UTC
From: pushpakr at yahoo dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.9 OS: Windows XP Pro
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pushpakr at yahoo dot com
New email:
PHP Version: OS:

 

 [2009-04-24 11:58 UTC] pushpakr at yahoo dot com
Description:
------------
I have installed PHP 5.2.9 and APACHE TOMCAT 5.5.27. When I try to run the phpinfo test page I get the following error.
java.lang.UnsatisfiedLinkError: startup
	net.php.servlet.startup(Native Method)
	net.php.servlet.init(servlet.java:158)

I have made sure that php5srvlt.jar is in tomcat\commons\lib and the library=php5servlet line is servlet.properties and reflect.properties file is correct.
I have php5servlet.dll and php5ts.dll in C:\php folder and C:\php has been set to PATH.
I have even tried putting in c:\windows\system32 folder.

I have also put this tp php.ini file
[Java]
java.class.path = "c:\php\ext\php_java.jar"
java.home = "D:\jdk1.5.0_18"
java.library = "D:\jdk1.5.0_18\jre\bin\client\jvm.dll"
java.library.path = "c:\php\ext;D:\jdk1.5.0_18\jre\lib"

BUT STILL NOT WORKING. PLEASE HELP.
CAN SOMEONE PLEASE PROVIDE ME php5srvlt.jar, php5servlet.dll and php5ts.dll file...just to see if something is wrong with the version I have.

Actual result:
--------------
type Exception report

message 

description The server encountered an internal error () that prevented it from fulfilling this request.

exception 

javax.servlet.ServletException: Servlet.init() for servlet php threw exception
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:875)
	org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
	org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
	org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
	org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
	java.lang.Thread.run(Thread.java:595)


root cause 

java.lang.UnsatisfiedLinkError: startup
	net.php.servlet.startup(Native Method)
	net.php.servlet.init(servlet.java:158)
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:174)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:875)
	org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
	org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
	org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
	org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
	java.lang.Thread.run(Thread.java:595)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-04-24 13:25 UTC] jani@php.net
http://www.php.net/manual/en/intro.java.php

Note: All this is totally unsupported.

 [2009-04-24 22:13 UTC] pushpakr at yahoo dot com
Why has this been categorized bogus?
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 02:05:45 2022 UTC