php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4797 Access Violation cause
Submitted: 2000-06-03 20:41 UTC Modified: 2002-02-10 00:00 UTC
From: tpowell at villageauction dot com Assigned:
Status: No Feedback Package: MSSQL related
PHP Version: php4-200006081545 OS: WinNT 4.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tpowell at villageauction dot com
New email:
PHP Version: OS:

 

 [2000-06-03 20:41 UTC] tpowell at villageauction dot com
I was getting the same error as in report 4540.  After poking through the source a bit, I found that it was caused by the mssql_globals structure not being properly initialized.  A quick fix was to add the line:
MS_SQL_G(get_column_content)= php_mssql_get_column_content_with_type;

before the line:
MS_SQL_G(get_column_content(mssql_ptr, j, &result->data[i][j-1], column_types[j-1]));

in PHP_FUNCTION(mssql_query)

However, since this doesn't fix the other parts of the structure that weren't initialized, there are likely other functions where will still be broken.

Tim

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-06-05 19:34 UTC] fmk at cvs dot php dot net
The fix you applied is not needed.

MS_SQL_G(get_column_content)= php_mssql_get_column_content_with_type

is called correctly during initialization.
 [2000-06-12 23:24 UTC] tpowell at villageauction dot com
I tried this again on php4-200006081545 and it seems to have the same problem.  It still appears that the module isn't peoperly being initialized



 [2000-06-12 23:41 UTC] zeev at cvs dot php dot net
I just submitted a fix to the CVS.  Can you test it?
 [2000-06-13 19:05 UTC] tpowell at villageauction dot com
I just tried it an got a "Tried to access invalid memory location" error.  Also, on another page with phpinfo() it did not show that the mssql module was loading.  When I have more time I'll try poking around a bit more to try to figure out whats going on.  But the short answer is that it still isn't working.
 [2002-02-10 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC