php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47923 Make search box remember entered search on results page
Submitted: 2009-04-08 08:59 UTC Modified: 2009-05-18 07:01 UTC
Votes:3
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: gerry dot spm+phpBug at gmail dot com Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS: Ubuntu Intrepid
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gerry dot spm+phpBug at gmail dot com
New email:
PHP Version: OS:

 

 [2009-04-08 08:59 UTC] gerry dot spm+phpBug at gmail dot com
Description:
------------
Feature request:
On most search result pages (across the web) the standard is to refill the search query on the results page so that it's easy to alter the query. However on php.net the search returns to a blank text field on the results page. Just one example of when this is quite annoying is when you want to switch from a "function list" search to an "online documentation" search using the same query, you have to retype your query again.

Note: This has of course taken me more time to report than it will ever save me, so I'm clearly not doing it for my own benefit. It's a small change but I imagine there are quite a lot of developers who have been silently annoyed by it and not reporting because of the reporting time issue associated with such a small feature request. :)

Kind Regards

 ~ Gerry

Reproduce code:
---------------
Search for something on php.net

Expected result:
----------------
Your search query is refilled in the search box on the results page

Actual result:
--------------
The search box is empty

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-08 13:45 UTC] danbrown@php.net
This was a feature that once existed, but was removed due to an 
overwhelming disapproval for it by the community.

In any case, thank you for your suggestion!
 [2009-05-10 04:24 UTC] gerry dot spm+phpBug at gmail dot com
The feature I imagine you are referring to is:
http://bugs.php.net/bug.php?id=25786

I saw that issue prior to posting this request and I am complete agreeance with the decision made on the issue. At first glance this may seem like the same thing, but they are actually different cases.

In the original problem the search wasn't just being populated on the results page, but it was being filled in every time the search field was displayed. I was actually using the PHP site when that issue existed and it was very annoy so I certainly do not want to bring that back. My request was different as it specifically specified that this should only happen on the the "results" page as is the standard across the web.

If every time you went to Google to do a search the search box was pre-populated with the query that you made the day before, this would be annoying. However what Google (and most other searches on the web) does do is refill your query on the results page as you have just entered it on the previous search page so it is relevant and saves you from having to retype the entire query when you just wish to slightly modify it. It works on the basis that the majority of the time when you go to the search page you will be searching for something completely new, but if you are doing a search from the results page then you will probably only be redefining your search to get better results for the thing that you were searching for.

I think the person who initially added the feature didn't think it through too well and thus ended up getting a good feature chucked out because of a bad implementation.

I didn't address the related issue in my original report as I knew it would only confuse the issue, however I hope I have clearly explained the difference between the two and why one is bad and the other is good. The PHP search is fantastic, but I think this one small change would bring it a step closer to perfection and aid usability.

Best Regards

 ~ Gerry
 [2009-05-18 00:00 UTC] gerry dot spm+phpBug at gmail dot com
I don't wish to be rude as I do appreciate all the work you guys do, but it's just sad that bugs just get closed without discussion. As soon as a dev has their say, that's it, case closed, no possibility that there could have been a misunderstanding.

This isn't the first time this has happened with something I've posted. It's the reason I haven't bothered posting a report in so long. I really don't want to lay into anybody about this, but I do wonder how many bugs get ignored because of the way the reports are handled.

:(
 [2009-05-18 07:01 UTC] bjori@php.net
> As soon as a dev has their say, that's it,
> case closed, no possibility that there
> could have been a misunderstanding.

This is totally not true.
The bugtracker is however *not* a discussion forum.
All decisions are made on public mailinglists where both "developers" and "general users" participate in discussions and make decisions.

If you want your voice heard, then participate on the lists.
Stop spreading FUD about being ignored when you do not even care enough to subscribe to these lists.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu May 30 10:01:33 2024 UTC