php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47822 No input file specified NOW FOUND OUT WHY
Submitted: 2009-03-28 22:43 UTC Modified: 2009-03-29 06:08 UTC
From: erik at media dot virogo dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.9 OS: W2K3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: erik at media dot virogo dot com
New email:
PHP Version: OS:

 

 [2009-03-28 22:43 UTC] erik at media dot virogo dot com
Description:
------------
I had some weird problems for months now trying to solve the No input file specified error.
And all I found on the web couldn't help me.
As I used to recall similair strange errors with a IIS6/W2K3/PHP5/MySQL5.x, I got back to the basics.
And as always, it is the compatibility between extensions from PHP versus MySQL.

One which now succesfully works for my multi hosted environment: PHP 5.2.9-1 & MySQL 5.0.77

Any other combination of higher versions of MySQL will definately give you trouble.

As for what I tried in any order:
- Switched of EXIF extension as it has caused trouble
- Never used the doc_root = , so was already empty/disabled also
- Had minor succes moving PHP from C:\Program Files\PHP to C:\PHP
- Tried numerous other PHP5 versions versus MySQL 5.1
- Multi host environment weirdo: Site 1 works, Site 2 doesn't especially with pages using MySQL

So finally, installed over and over until to one which succesfully works: PHP 5.2.9-1 & MySQL 5.0.77

Maybe the mysql extension needs a lookup against MySQL 5.1 in a multi host environment.

Reproduce code:
---------------
One way of getting a No input file specified error, is to do the following:
Install PHP and MySQL 5.1 on IIS6/W2K3
Make a custom errorpage for 404 errors which in fact is a php-script (e.g. redirect.php)
Now try visiting your domain for index.php, OK
Now try visiting your domain for a non exsisting php-script and bingo!
No input file specified.


Expected result:
----------------
The redirect.php in action

Actual result:
--------------
No input file specified.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-29 06:08 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

libmysql 5.1 is not currently supported with PHP, it's not binary compatible. So you need to make sure that the PHP directory comes in the %PATH% before MySQL.

The shipped libmysql is 5.0 and that talk to a 5.1 server without issue.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Thu Feb 09 13:03:40 2023 UTC