php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47821 Cannot get Postgres loaded even tho PHP.INI indicates that it s/b loaded ?
Submitted: 2009-03-28 15:18 UTC Modified: 2009-03-28 16:52 UTC
From: terrylipford at gmail dot com Assigned: pajoye (profile)
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.2.9 OS: Vista
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: terrylipford at gmail dot com
New email:
PHP Version: OS:

 

 [2009-03-28 15:18 UTC] terrylipford at gmail dot com
Description:
------------
My PHP.INI file has the text set to have Postgres extension loaded, but it does not load because it does not show up in a PHPINFO().  Any other change I make to PHP.INI does show up, but Postgres will not.

PGAdmin runs just fine, but any attempt to call a Postgres function from a PHP page fails.

Reproduce code:
---------------
from my PHP.INI file;

;extension=php_pdo_sqlite.dll
extension=php_pgsql.dll

From my HTTPD.CONF file;

LoadModule php5_module "C:\Program Files (x86)\PHP\php5apache2_2.dll"
AddType application/x-httpd-php .php
AcceptPathInfo on
PHPIniDir "C:\Program Files (x86)\PHP\php.ini"

Expected result:
----------------
As a long time PHP and Postgres developer/user/admin, I have never had this happen before ?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-28 16:52 UTC] pajoye@php.net
Be sure to have the libpq.dll in you path, please ask further questions in the php setup or windows mailing list.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun May 19 15:01:31 2024 UTC