php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47709 file_get_contents causes kernel to load ipv6-modul
Submitted: 2009-03-18 20:13 UTC Modified: 2009-03-21 23:15 UTC
From: jh2000 at root24 dot eu Assigned:
Status: Not a bug Package: Network related
PHP Version: 5.2.9 OS: Debian
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jh2000 at root24 dot eu
New email:
PHP Version: OS:

 

 [2009-03-18 20:13 UTC] jh2000 at root24 dot eu
Description:
------------
php with ipv6 support tris to get ipv6 ready even if it?s not needed.
I noticed this while updating the kernel to enable ipv6. I haven't done a restart yet, so there is the ipv6 module for the new kernel and the old kernel without ipv6 still running, php does something which causes the system to try to load the module (failing, as expected since it?s the wrong version)
There should just be an additional check whether php realy needs ipv6 for the url or not. (the target url has no AAAA entry and no ipv6 so far)

Reproduce code:
---------------
---
From manual page: function.file-get-contents
---
<?
echo file_get_contents("http://somewhere.internet.tld/file");
?>


Expected result:
----------------
content of url

Actual result:
--------------
content of url (with ipv6-failure message in system-log)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-19 00:15 UTC] crrodriguez at opensuse dot org
PHP does not load kernel modules, it is the OS that does that.
 [2009-03-21 23:15 UTC] jani@php.net
This has nothing to do with PHP..
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 15 17:01:42 2019 UTC