php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47645 PHP_Archive / Archive.php missing
Submitted: 2009-03-13 15:07 UTC Modified: 2009-03-26 13:57 UTC
From: lneve at mail dot nih dot gov Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.3.0beta1 OS: Solaris 10 x86
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: lneve at mail dot nih dot gov
New email:
PHP Version: OS:

 

 [2009-03-13 15:07 UTC] lneve at mail dot nih dot gov
Description:
------------
This is the same as bug #45726, which was CLOSED but should not have been since the bug persists.

Here is the relevant build output:

Generating phar.php
Generating phar.phar
Pear package PHP_Archive or Archive.php class file not found.
directorytreeiterator.inc
directorygraphiterator.inc
clicommand.inc
invertedregexiterator.inc
pharcommand.inc
phar.inc

Please let me know what else I can provide to help you troubleshoot and fix this problem.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-26 13:57 UTC] cellog@php.net
The bug you quote, #45726 was a bug because after not finding PHP_Archive, the build would fail.

As your output shows, phar.phar is indeed successfully built without PHP_Archive, which is expected.  The difference here is that phar.phar cannot create a phar archive that contains the PHP_Archive class.  Otherwise, phar.phar works great.

I'm marking this bogus because there is no bug.

If you do indeed want to take advantage of PHP_Archive, simply install it:

pear install PHP_Archive-beta

and then make PHP again.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Sep 25 08:01:25 2020 UTC