php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47604 crashes on big MySQL function
Submitted: 2009-03-09 12:53 UTC Modified: 2009-03-11 13:54 UTC
From: valkum at globalgameport dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.2.9 OS: Debian Etch
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: valkum at globalgameport dot com
New email:
PHP Version: OS:

 

 [2009-03-09 12:53 UTC] valkum at globalgameport dot com
Description:
------------
When i run the php script with CLI i get a Segmentation Fault.
The code reads out a table and convert it from iso-8859 to utf-8

But on one table i get a Segmentation Fault.

The Database ist a Joomla 1.0.x Database with more then 100 records.

i test the Script on Debian Lenny but the Segmentation Fault is still there.

Reproduce code:
---------------
A little bit changed version of http://blog.dopefreshtight.de/artikel/von-iso-8859-1-zu-utf-8-in-php-und-mysql#convert

Expected result:
----------------
A converted MySql Database.

Actual result:
--------------
Segmentation Fault

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-09 14:23 UTC] kalle@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a short but complete example script to be able to reproduce
this bug ourselves. 

A proper reproducing script starts with <?php and ends with ?>,
is max. 10-20 lines long and does not require any external 
resources such as databases, etc. If the script requires a 
database to demonstrate the issue, please make sure it creates 
all necessary tables, stored procedures etc.

Please avoid embedding huge scripts into the report.


 [2009-03-10 23:14 UTC] valkum at globalgameport dot com
We could restrict the problem.

The Problem is not the MySQL Funktion. No its a specific field in this database.
The Problem is taht a field with tags from a joomla installtion wont be converted to utf8.
I think it is a problem with a link or html tags.

Maybe it isn't a mysql bug. It is a utf8-encode bug or should it be right??
 [2009-03-11 13:54 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 11:01:32 2024 UTC