|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47503 apache start terminated
Submitted: 2009-02-25 17:02 UTC Modified: 2009-03-18 01:00 UTC
Avg. Score:4.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: roland dot ziegler at bsgti dot ch Assigned:
Status: No Feedback Package: Apache related
PHP Version: 5.2.8 OS: Fedora Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: roland dot ziegler at bsgti dot ch
New email:
PHP Version: OS:


 [2009-02-25 17:02 UTC] roland dot ziegler at bsgti dot ch
Similar to Bug #17147

Installed Apache 1.3.41 and PHP 5.2.8 - after start i got this message:

Syntax error on line 206 of /usr/local/apache_1.3.41/conf/httpd.conf: Cannot load /usr/local/apache_1.3.41/libexec/ into server: /usr/local/apache_1.3.41/libexec/ undefined symbol: sapi_globals /usr/local/apache_1.3.41/bin/apachectl start: httpd could not be started


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-25 20:36 UTC]
Check that your httpd.conf (and possible included configuration files 
in it) do not load anything but the You should also 
consider upgrading to Apache 2. 

Also, what was the configure line you used when compiling PHP?
 [2009-02-26 12:35 UTC] roland dot ziegler at bsgti dot ch
This is my configure line:

./configure --with-apxs=/usr/local/apache_1.3.41/bin/apxs

I also tried it without using other modules, but without success.

I also tried to install apache2 first, but my server is inside a very strictly ruled network and is not allowed to connect to the internet. Solving the rpm-dependencies is very difficult in this case.
 [2009-03-10 10:39 UTC]
Check the output of this:

# ldd /usr/local/apache_1.3.41/libexec/

Then fix your /etc/ to contain the missing paths, run ldconfig and try again to start apache..
 [2009-03-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2009-06-27 00:44 UTC] himanshuvj at gmail dot com
I reconfigured PHP, this time providing --with-pic option (in addition to other options that you might have been using right now), followed by make and make install. this basically generated the new DSO file which is used by apache. That solved the problem for me.

I did this because I got the hint from this page on apache's site: 
It tells you that the PHP source code should better be compiled for position independent code (PIC).

I would also recommend that before doing this reconfiguration check for and remove any old *.so objects that are present. Infact I un-tarred the  PHP source in a new location every time and then did the reconfiguration.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 08:01:28 2024 UTC