php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47403 preg_replace function
Submitted: 2009-02-16 11:40 UTC Modified: 2009-02-16 13:52 UTC
From: jignasha_86 at yahoo dot co dot in Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 5.2.9RC2 OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jignasha_86 at yahoo dot co dot in
New email:
PHP Version: OS:

 

 [2009-02-16 11:40 UTC] jignasha_86 at yahoo dot co dot in
Description:
------------
In preg_replace function,you are replacing one string to other
if replacing string contains $ sign in it,then preg_replace suppress
$ sign and 2 charcaters after that $ sign
This happens in all PHP 5 versions

Reproduce code:
---------------
$pattern[] = "/_BASEURL_/";
        //$pattern[] = "/_BASELOGIN_/";
	$pattern[] = "/_SENDERNAME_/";
	$pattern[] = "/_ISSUETITLE_/";
	$pattern[] = "/\'\'/";
        $replacement[] = BASEURL;
	$replacement[] = $msg_sendername;
	$replacement[] = $istitle;
	$replacement[] = "'";
        
	
	$msg_body = preg_replace($pattern, $replacement, $msg_body);

 if $istitle = "This is $888 ruppes";

 Then It will replace it with "This is 8 rupees"
 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-16 13:52 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

You have a replacement back reference and that only accepts 2 numbers, $0 - $99.

So $88 -> '' and hence why you see 8.

If you escape the replacement correctly then it will work.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 18 08:03:18 2022 UTC