php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47354 Windows Installer doesn't contain php_pdo.dll, php_mhash.dll, php_mcrypt.dll...
Submitted: 2009-02-10 17:05 UTC Modified: 2009-02-11 09:26 UTC
From: lucazavarella at gmail dot com Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.3 OS: Vista Ultimate
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lucazavarella at gmail dot com
New email:
PHP Version: OS:

 

 [2009-02-10 17:05 UTC] lucazavarella at gmail dot com
Description:
------------
When I launch php-5.3-win32-VC6-x86-latest.msi (VC6, 2009-Feb-10 16:00:00, sha1: ae51121e28a388fbe49994f47706e2c1d3cf12f0) and I choose to install all the extensions, the installer doesn't install extensions like php_pdo.dll, php_mhash.dll, php_mcrypt.dll, php_fdf.dll.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-10 17:18 UTC] lucazavarella at gmail dot com
The compiled version (not the installer, sha1: 1d09af301d01d20711f8a31fdd1766d3649dc22e) has the same problem too
 [2009-02-10 21:51 UTC] bjori@php.net
reclassified.
 [2009-02-11 08:38 UTC] pajoye@php.net
> php_pdo.dll

built in php

> php_mhash.dll

built in php

> php_mcrypt.dll

built in php

> php_fdf.dll.

Not in php anymore since long

 [2009-02-11 09:10 UTC] lucazavarella at gmail dot com
Yes, but after the installation, I can't find php_pdo.dll, php_mhash.dll, php_mcrypt.dll in the EXT folder. I can't find them in the same folder of the no-install-version too...
Am I missing anything?

Thank you
 [2009-02-11 09:16 UTC] pajoye@php.net
what's about running php.exe -m or looking at a phpinfo() output? 
 [2009-02-11 09:26 UTC] lucazavarella at gmail dot com
You are right, in phpinfo() I can see mcrypt, mhash and PDO. They are already built in this new version.

Thank you for your support
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 21:03:33 2021 UTC