php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47238 function fails to run on IIS6.0
Submitted: 2009-01-29 08:12 UTC Modified: 2009-02-10 10:46 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: helga79 at rediffmail dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.8 OS: Windows 2003
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: helga79 at rediffmail dot com
New email:
PHP Version: OS:

 

 [2009-01-29 08:12 UTC] helga79 at rediffmail dot com
Description:
------------
The below php script when run from command prompt runs successfully gives the output returned by perl script.
But when run on browser IIS6.0 php (CGI/Fast CGI) I get error.
I have pasted the test.php script. the perl script returns a numeric value.

Reproduce code:
---------------
<?php
$cmd="perl uploadpost.pl"; 
$pipe = popen("$cmd",'r');    
   while($s = fgets($pipe, 2048)) {
	  $output .= $s;
   };
   pclose($pipe);
   if (preg_match("/^\d+$/",$output)) {
      $sid=$output;
      echo "success.$sid";	
   }else{
echo "upload failed";
            }
?>

Expected result:
----------------
Success and $sid some numeric value which is returnes by the perl script

Actual result:
--------------
Warning: popen(perl uploadpost.pl,r): No error in D:\WFM_vDev_Tk\test.php on line 25 pipe value. Warning: fgets(): supplied argument is not a valid stream resource in D:\WFM_vDev_Tk\test.php on line 27 Warning: pclose(): supplied argument is not a valid stream resource in D:\WFM_vDev_Tk\test.php on line 30 .


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-10 10:46 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

IIS being unable to run Perl binary because of some privilege issue -> not PHP problem.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 15 19:01:30 2024 UTC