php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47234 Win32 Installer missing MSSQL module.
Submitted: 2009-01-29 02:10 UTC Modified: 2009-02-11 17:21 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: sholsinger at gmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.8 OS: Windows Server 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sholsinger at gmail dot com
New email:
PHP Version: OS:

 

 [2009-01-29 02:10 UTC] sholsinger at gmail dot com
Description:
------------
The Windows Installer for PHP does not include the option to install the mssql module. After reviewing the build command that built the binaries, it seems the option to enable mssql module was not on.

The module _IS_ included in the zipped package, and I was able to salvage the installation by grabbing the module from there.

For anyone not well versed with PHP, this type of issue might have been more difficult to work out. Especially since the primary purpose of an Installer is to simplify installation and configuration. In most cases, if PHP is being setup on Windows it is likely that the user intends to use PHP with Microsoft SQL Server, and without the mssql module they cannot do that.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-11 17:21 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 06:05:46 2022 UTC