php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47131 SOAP Extension Ignores "user_agent" From Php.ini
Submitted: 2009-01-16 16:10 UTC Modified: 2009-01-25 18:13 UTC
From: user2037 at ymail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.2.8 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
50 - 3 = ?
Subscribe to this entry?

 
 [2009-01-16 16:10 UTC] user2037 at ymail dot com
Description:
------------
When accessing a web service using the SoapClient class of PHP Group's SOAP extension the "user_agent" configuration is ignored. If one does not explicitly specify the user agent then it stands to reason that PHP's user agent should be used instead of some hard-coded value.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-25 18:13 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

This bug was already reported & fixed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 21:03:38 2021 UTC