php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47124 echo sentence works in the url toolbar
Submitted: 2009-01-16 07:37 UTC Modified: 2009-01-16 11:06 UTC
From: luis dot antonio dot comi at gmail dot com Assigned:
Status: Not a bug Package: URL related
PHP Version: 5.2.8 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: luis dot antonio dot comi at gmail dot com
New email:
PHP Version: OS:

 

 [2009-01-16 07:37 UTC] luis dot antonio dot comi at gmail dot com
Description:
------------
It's possible write echo sentence in the url toolbar and works the sentence.

Reproduce code:
---------------
echo variable&variable


Expected result:
----------------
I don't know what are the possible problems about this bug.

But I think that is dangerous that a sentence can run in the url toolbar.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-16 07:38 UTC] luis dot antonio dot comi at gmail dot com
The correct example is 

http://php_file.php?echo variable&variable

Written in the toolbar
 [2009-01-16 11:06 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jan 27 20:03:37 2022 UTC