php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47094 aspell-15.dll causes problem with other applications
Submitted: 2009-01-14 00:11 UTC Modified: 2009-02-09 14:41 UTC
Votes:2
Avg. Score:2.5 ± 1.5
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: viper_sb at yahoo dot com Assigned: pajoye (profile)
Status: Not a bug Package: Pspell related
PHP Version: 5.2.8 OS: win32 only - Windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: viper_sb at yahoo dot com
New email:
PHP Version: OS:

 

 [2009-01-14 00:11 UTC] viper_sb at yahoo dot com
Description:
------------
Ok let me explain what happens.

I upgraded to 5.2.8 on windows, and suddenly pidgin (program) stopped working, kept crashing, finally I got a debug build and found the error.

My PHP directory IS in the PATH, so aspell-15.dll was being referenced by pidgin for whatever reason.

Windows Version 5.1 Build 2600 Service Pack 3

C:\Program Files\Pidgin\pidgin.exe caused a Privileged Instruction at location 00f9cef6 in module C:\Program Files\Apache Group\php\aspell-15.dll.

Until this dll's been added I'm not had a problem with PHP being in the PATH, in fact I prefer it that way. For now since I don't use the spelling features I deleted the dll, and php seems fine.

Maybe this isn't a "bug" but IMO a dll from php should not interfere with other programs. Maybe the solution is to not have PHP in the PATH and if that's the recommend way of doing it then fine, consider this closed.

Or perhaps aspell dll can be put within the ext directory?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-09 14:41 UTC] pajoye@php.net
Not a php issue.

Mixing binaries built using various compilers and CRT cannot work. Be sure to have separate path for pidgin and php. Or simply keep the pidgin dlls inside the pidgin install, where it will find them.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Sep 20 12:01:27 2019 UTC