php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47073 don�t connect to mssql
Submitted: 2009-01-12 10:15 UTC Modified: 2009-01-12 15:44 UTC
From: joao dot rebelo at pchouse dot pt Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.2.8 OS: Windows XP SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
19 + 28 = ?
Subscribe to this entry?

 
 [2009-01-12 10:15 UTC] joao dot rebelo at pchouse dot pt
Description:
------------
Upgrading from PHP 5.2.6 to PHP 5.2.8 and had stopping the connection with MSSQL, with the message 'no driver installed' even after installing the driver from Microsoft web site and installing and configure php.ini to load the drive when I rollback to PHP 5.2.6 everything works fine. 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-12 10:35 UTC] pajoye@php.net
Please show us some script. Also the driver from Microsoft is not compatible with PHP's mssql drivers. They use differenet APIs.
 [2009-01-12 15:28 UTC] joao dot rebelo at pchouse dot pt
function datamssql(){
	
	if(!$mssqldb){	
	global $mssql_host, $mssql_user, $mssql_password, $mssql_database;

	$mssqldb = new Zend_Db_Adapter_Pdo_Mssql(array(
    'host'     => $mssql_host,
    'username' => $mssql_user,
    'password' => $mssql_password,
    'dbname'   => $mssql_database
	));
	}

	return $mssqldb;
	} // end mssql connection


Fatal error: Uncaught exception 'Zend_Db_Adapter_Exception' with message 'The mssql driver is not currently installed' in C:\wamp\virtualhost\pchousecms\cmsadmin\include\Zend\Db\Adapter\Pdo\Abstract.php:103 Stack trace: #0 C:\wamp\virtualhost\pchousecms\cmsadmin\include\Zend\Db\Adapter\Pdo\Mssql.php(135): Zend_Db_Adapter_Pdo_Abstract->_connect() #1 C:\wamp\virtualhost\pchousecms\cmsadmin\include\Zend\Db\Adapter\Abstract.php(389): Zend_Db_Adapter_Pdo_Mssql->_connect() #2 C:\wamp\virtualhost\pchousecms\cmsadmin\include\Zend\Db\Adapter\Pdo\Abstract.php(205): Zend_Db_Adapter_Abstract->query('SELECT COUNT(no...', Array) #3 C:\wamp\virtualhost\pchousecms\cmsadmin\include\connector\backoffice\wintouch\subfamilia.class.php(351): Zend_Db_Adapter_Pdo_Abstract->query('SELECT COUNT(no...') #4 C:\wamp\virtualhost\pchousecms\cmsadmin\include\connector\subfamilia\subfamilia.php(16): subfamilia->countrec() #5 {main} thrown in C:\wamp\virtualhost\pchousecms\cmsadmin\include\Zend\Db\Adapter\Pdo\Abstract.php on line 103

I also had copy the ntwdblib.dll as i did in on PHP 5.2.6 to work, but doesn?t work
 [2009-01-12 15:36 UTC] pajoye@php.net
Well, the error is clear. You did not install the mssql driver. But as we are not Zend and has little to do with the Zend framework, I would suggest to ask for some support there instead.

Not a php bug > bogus.
 [2009-01-12 15:44 UTC] joao dot rebelo at pchouse dot pt
Ok. Thanks, it was the php_pdo_mysql that was not loaded, only php_mssql was loaded.
Now is working.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 10:03:51 2022 UTC