php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47043 Compilation fails on Ming library
Submitted: 2009-01-08 21:38 UTC Modified: 2009-01-26 16:27 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: john at jcoppens dot com Assigned:
Status: Wont fix Package: Ming related
PHP Version: 5.2CVS-2009-01-08 (snap) OS: Linux 386
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john at jcoppens dot com
New email:
PHP Version: OS:

 

 [2009-01-08 21:38 UTC] john at jcoppens dot com
Description:
------------
Compiling PHP with the following configuration:

./configure --with-mysql=/opt/mysql -with-mysqli --with-msql=/usr/local/msql \ 
--with-apxs \                                        
--with-ming --with-zlib --with-bz2 --enable-exif --enable-ftp \  
--with-gd --enable-gd-native-ttf --with-ttf=/usr --enable-dbase \
--with-freetype-dir=/usr --enable-sockets --with-t1lib \
--prefix=/usr --enable-mbstring --with-libxml-dir=/usr --with-pspell \
--with-config-file-path=\etc\apache

causes a lot of undefined references, apparently all related to the ming libraries.

Reproduce code:
---------------
configure with the above options,
make


Expected result:
----------------
Normal compilation

Actual result:
--------------
After a very long gcc command, probably near the end:

ext/ming/.libs/ming.o: In function `zim_swfdisplayitem_getRot':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1196: undefined reference to `SWFDisplayItem_get_rot'
ext/ming/.libs/ming.o: In function `zim_swfdisplayitem_getYSkew':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1181: undefined reference to `SWFDisplayItem_get_ySkew'
ext/ming/.libs/ming.o: In function `zim_swfdisplayitem_getXSkew':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1166: undefined reference to `SWFDisplayItem_get_xSkew'
ext/ming/.libs/ming.o: In function `zim_swfdisplayitem_getYScale':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1151: undefined reference to `SWFDisplayItem_get_yScale'
ext/ming/.libs/ming.o: In function `zim_swfdisplayitem_getXScale':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1136: undefined reference to `SWFDisplayItem_get_xScale'
ext/ming/.libs/ming.o: In function `zim_swfdisplayitem_getY':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1121: undefined reference to `SWFDisplayItem_get_y'
ext/ming/.libs/ming.o: In function `zim_swfdisplayitem_getX':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1106: undefined reference to `SWFDisplayItem_get_x'
ext/ming/.libs/ming.o: In function `zim_swffont_getShape':
/usr/local/src/programming/php-5.2.8/ext/ming/ming.c:1609: undefined reference to `SWFFont_getShape'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-26 12:47 UTC] jani@php.net
What's this: --with-config-file-path=\etc\apache ??? You really have such path? (hint: forward slashes..)

And what ming library version have you installed? And how?

 [2009-01-26 13:32 UTC] john at jcoppens dot com
> What's this: --with-config-file-path=\etc\apache ??? You really have
> such path? (hint: forward slashes..)

Evidently a typo. Just in case that was the cause, I retried with the right slashes. No change.

I first had Ming 0.3 installed, and was able to compile (at that time - last year) php 5.2.5 with Ming included. Now I got the list of undefined references, so I installed Ming 0.4. (ming-0.4.0.rc1).
I compiled and installed 0.4 with:
./configure --enable-php --enable-cpp --enable-perl --enable-perl
so it installed in /usr/local
 [2009-01-26 15:17 UTC] jani@php.net
So did you get the errors with 0.3a and PHP 5.2.8 or not? Please be 
specific which versions of which did or did not work. Now it's not 
quite clear..
 [2009-01-26 15:34 UTC] john at jcoppens dot com
Yes, I had the same errors. 

The errors were the motive to install 0.4, hoping 0.4 would resolve the undefined references.

John
 [2009-01-26 16:27 UTC] jani@php.net
As suggested by the "EXPERIMENTAL" status, this is truly experimental 
extension since it doesn't even compile. Apparently libming is also 
pretty much experimental since they chose to break BC between their 
0.4.x release and 0.3a which is the version PHP 5.2.x compiles fine 
with. You should use the extension that is bundled with the current 
libming version. Also note that ext/ming will be moved to PECL in PHP 
5.3.0. (and apparently abandoned..)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 27 03:01:24 2020 UTC