php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47026 php_pdo_pgsql.dll don't load
Submitted: 2009-01-07 12:26 UTC Modified: 2009-01-07 15:15 UTC
From: francois at frinux dot fr Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.2.8 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: francois at frinux dot fr
New email:
PHP Version: OS:

 

 [2009-01-07 12:26 UTC] francois at frinux dot fr
Description:
------------
phpinfo() reveals that there is no PDO drivers :
PDO support	enabled
PDO drivers 	no value

Allthough I enabled them in php.ini:
extension=php_pdo.dll
extension=php_pdo_pgsql.dll
extension=php_pgsql.dll

When I replace php_pdo_pgsql.dll from the 5.2.4 release it works fine.

Expected result:
----------------
PDO in phpinfo()
PDO support	enabled
PDO drivers 	pgsql 

Actual result:
--------------
PDO
PDO support	enabled
PDO drivers 	no value

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-07 12:27 UTC] francois at frinux dot fr
Works also fine with 5.2.5 version of php_pdo_pgsql.dll
 [2009-01-07 12:54 UTC] pajoye@php.net
Be sure you have the libpq.dll available in the php dir or in your path.
 [2009-01-07 13:13 UTC] francois at frinux dot fr
C:\Program Files\PostgreSQL\8.3\bin is in my PATH.
Furthermore, it can't be the proble mbecause all I'm doing is replacing the 5.2.8 dll by the 5.2.5 one.
 [2009-01-07 13:18 UTC] pajoye@php.net
It is.

Previous versions do not use the libpq.dll as it was statically linked.
 [2009-01-07 15:15 UTC] francois at frinux dot fr
Like I said, the lib is in my PATH. It is also in the php directory, and the extension is not loaded.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 21 02:01:35 2024 UTC