php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46963 Wrong redirect code
Submitted: 2008-12-28 13:12 UTC Modified: 2009-02-10 11:04 UTC
From: tiposchi at tiscali dot it Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 5.2.8 OS: GNU/Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tiposchi at tiscali dot it
New email:
PHP Version: OS:

 

 [2008-12-28 13:12 UTC] tiposchi at tiscali dot it
Description:
------------
This bug is the same of bug #32263, but that bug was closed years ago
and the problem is still there.

Reproduce code:
---------------
<?
header("Location: ciao.html");
?>

Expected result:
----------------
Status: 303

Actual result:
--------------
Status: 302 Moved Temporarily


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-10 11:04 UTC] tony2001@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

header("Location: ciao.html", true, 303); - is it THAT complex?

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Oct 28 12:03:36 2021 UTC