php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46931 html code error in the template of theme
Submitted: 2008-12-23 05:33 UTC Modified: 2008-12-24 01:56 UTC
From: haohappy@php.net Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: haohappy@php.net
New email:
PHP Version: OS:

 

 [2008-12-23 05:33 UTC] haohappy@php.net
Description:
------------
A blank page shows when browsing some doc files in Microsoft IE browser. That's because the PhD use a wrong format of template for generation HTML pages.


Reproduce code:
---------------
In the file phd/themes/php/chunkedhtml.php, there are two lines of code as below:
<title>$title</title>
<meta http-equiv="content-type" content="text/html; charset=UTF-8">

Expected result:
----------------
These codes should be changed to:
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
<title>$title</title>

We need to put the meta info before the <title>, then the IE can always recognize the charset correctly.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-23 05:39 UTC] haohappy@php.net
change some words.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Mar 22 06:01:26 2019 UTC