php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46909 COM object not allowing calls to methods
Submitted: 2008-12-19 20:33 UTC Modified: 2009-08-19 16:59 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: jmertic@php.net Assigned:
Status: Not a bug Package: COM related
PHP Version: 6CVS-2008-12-19 (snap) OS: Windows Server 2008 x64
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jmertic@php.net
New email:
PHP Version: OS:

 

 [2008-12-19 20:33 UTC] jmertic@php.net
Description:
------------
Having trouble access the COM methods for an object; getting Fatal errors that the method is undefined. Works fine under PHP 5.2.8 on the same machine.

Reproduce code:
---------------
$filename = 'Test File Name.txt';
$fso = new COM("Scripting.FileSystemObject");
$file = $fso->GetFile($filename);
echo $file;

Expected result:
----------------
testfi~1.txt

Actual result:
--------------
Fatal error: Call to undefined method com::GetFile()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-08-19 16:29 UTC] kalle@php.net
Dublicate of #45836, its because theres not any unicode support in com_dotnet yet
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 05:05:53 2022 UTC