php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46892 Run make to compile, comes back with error
Submitted: 2008-12-17 22:12 UTC Modified: 2008-12-18 03:19 UTC
From: adam dot jaber dot ctr at dla dot mil Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.2.8 OS: AIX 5.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: adam dot jaber dot ctr at dla dot mil
New email:
PHP Version: OS:

 

 [2008-12-17 22:12 UTC] adam dot jaber dot ctr at dla dot mil
Description:
------------
I set up php to work with apache and db2.  I try to run the make command to compile and keeps coming back with an error.  Apache httpd 2.2.10 is installed.  

Reproduce code:
---------------
#./configure --enable-cli --disable-cgi --with-apxs2=/usr/local/bin/apxs --with-ibm-db2=/data/db2/db2inst1/sqllib

# make

#/bin/sh /usr/local/src/php5/php-5.2.8/libtool --silent --preserve-dup-deps --mode=compile gcc -I/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib -Iext/pcre/ -I/usr/local/src/php5/php-5.2.8/ext/pcre/ -DPHP_ATOM_INC -I/usr/local/src/php5/php-5.2.8/include -I/usr/local/src/php5/php-5.2.8/main -I/usr/local/src/php5/php-5.2.8 -I/usr/include/libxml2 -I/usr/local/src/php5/php-5.2.8/ext/date/lib -I/usr/local/src/php5/php-5.2.8/TSRM -I/usr/local/src/php5/php-5.2.8/Zend    -I/usr/include -g -O2   -c /usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_chartables.c -o ext/pcre/pcrelib/pcre_chartables.lo 
In file included from /usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_chartables.c:25:
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:976: error: parse error before 'BOOL'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:976: warning: no semicolon at end of struct or union
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:980: error: parse error before '}' token
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:980: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1027: error: parse error before 'BOOL'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1027: warning: no semicolon at end of struct or union
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1028: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1029: error: parse error before 'noteol'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1029: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1030: error: parse error before 'utf8'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1030: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1031: error: parse error before 'jscript_compat'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1031: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1032: error: parse error before 'endonly'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1032: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1033: error: parse error before 'notempty'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1033: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1034: error: parse error before 'partial'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1034: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1035: error: parse error before 'hitend'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1035: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1036: error: parse error before 'bsr_anycrlf'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1036: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1049: error: parse error before '}' token
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1049: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1137: error: parse error before 'php__pcre_is_newline'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1138: error: parse error before 'BOOL'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1138: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1143: error: parse error before 'php__pcre_was_newline'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1144: error: parse error before 'BOOL'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1144: warning: data definition has no type or storage class
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1145: error: parse error before 'php__pcre_xclass'
/usr/local/src/php5/php-5.2.8/ext/pcre/pcrelib/pcre_internal.h:1145: warning: data definition has no type or storage class
make: 1254-004 The error code from the last command is 1.


Stop.


Expected result:
----------------
Want to be able to compile php.

Actual result:
--------------
NEED HELP!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-18 03:19 UTC] scottmac@php.net
Duplicate of bug #46040

Though this is an upstream bug see http://bugs.exim.org/show_bug.cgi?id=761
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Feb 22 23:01:25 2020 UTC