php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4687 Undefined symbol stops imap being included
Submitted: 2000-05-30 05:23 UTC Modified: 2000-10-19 18:49 UTC
From: carwyn at carwyn dot demon dot co dot uk Assigned:
Status: Closed Package: *General Issues
PHP Version: 4.0.0 Release OS: Redhat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: carwyn at carwyn dot demon dot co dot uk
New email:
PHP Version: OS:

 

 [2000-05-30 05:23 UTC] carwyn at carwyn dot demon dot co dot uk
Having trouble getting imap to work, everything else in the setup works but fails as soon as imap is added.

PHP4 Release
============
./configure --with-apxs=/usr/local/apache/bin/apxs \
	--enable-track-vars --enable-trans-sid --enable-ftp \
	--with-pgsql=/usr/local/pgsql \
	--with-openssl=/usr/local/ssl \
	--with-imap=/usr/lib

Apache 1.3.12
=============
./configure --enable-module=ssl \
	--enable-module=so \
	--enable-module=log_referer \
	--enable-module=vhost_alias \
	--enable-module=headers \
	--with-perl=/usr/bin/perl


To get PHP to compile with imap I did:

ln -s /usr/lib/c-client.a /usr/lib/libc-client.a

But then on loading the module I get:

Starting httpd: Syntax error on line 207 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: gss_mech_krb5

"grep gss_mech_krb5 /usr/lib/c-client.a" matches true though and LD_LIBRARY_PATH has /usr/lib in as well as being in /etc/ld.so.conf.

Help! a response would be great if you could as I really need imap working.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-05-31 07:51 UTC] joey at cvs dot php dot net
Looks as though your libc-client was linked against
kerberos libs.

This appears to be standard with RedHat 6.2, as there 
is at least one duplicate of this bug...#4424.

I would reccomend getting the libc-client.a source
from U. Wash. and compiling it yourself, or tracking
down whichever lib it is that defines this symbol and
adding it to your EXTRA_LIBS in you apache Makefile.

BTW, "grep"ing a library for a symbol does not tell you
if it is resolved in that lib or not, only if it is used/declared.

Try reading the manpage on nm...it will make your life easier.
 [2000-05-31 07:52 UTC] joey at cvs dot php dot net
Forgot to close it...
 [2000-06-01 07:20 UTC] joey at cvs dot php dot net
>From: Steve Langasek <vorlon@netexpress.net>
>
>The following line should be used when linking in libc-client under RedHat
>6.2:
>"-L/usr/kerberos/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err"
>
>However, it seems to me that this should be passed as an option to the PHP
>build instead of being set in the Apache Makefile.


Thanks, Steve! And you are right about passing options to PHP build...it was
VERY early (or possibly very late).


 [2000-10-19 18:49 UTC] rasmus@php.net
This issue is now properly fixed by passing --with-kerberos to the PHP configure script.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC