php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46726 Incorrect HTML output
Submitted: 2008-12-01 20:05 UTC Modified: 2009-01-01 22:20 UTC
From: ian dot back at bpm1 dot com Assigned: bjori (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ian dot back at bpm1 dot com
New email:
PHP Version: OS:

 

 [2008-12-01 20:05 UTC] ian dot back at bpm1 dot com
Description:
------------
The function definition pages in the documentation all incorrectly nest <dd> elements inside <dt> elements, which does not follow the HTML spec.


Reproduce code:
---------------
From: http://uk3.php.net/manual/en/function.iconv.php


 <div class="refsect1 parameters">
  <h3 class="title">Parameters</h3>
  <p class="para">
   <dl>

    <dt>

     <span class="term"><i><tt class="parameter">in_charset</tt></i>

</span>

     <dd>

      <p class="para">
       The input charset.
      </p>
     </dd>

    </dt>




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-01 22:20 UTC] bjori@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 03:05:52 2022 UTC