php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46635 Unable to load extention
Submitted: 2008-11-20 21:30 UTC Modified: 2009-05-26 08:00 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: R dot Scholtens at Onninet dot com Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.2.6 OS: Windows 2003 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: R dot Scholtens at Onninet dot com
New email:
PHP Version: OS:

 

 [2008-11-20 21:30 UTC] R dot Scholtens at Onninet dot com
Description:
------------
The php_mssql.dll extension is failing to load,
apache is giving the following error: 

PHP Warning:  PHP Startup: Unable to load dynamic library 'D:\\Server\\Php\\ext\\php_mssql.dll' - The specified module could not be found.\r\n in Unknown on line 0

The extension is in that directory but is not seeming to load.
The file ntwdblib.dll is already in system32 and it still keeps failing.

Current settings:
extension_dir = "D:\Server\Php\ext\"

extension=php_mssql.dll

Installation from the Native SQL client from:
http://www.microsoft.com/downloads/details.aspx?familyid=d09c1d60-a13c-4479-9b91-9e8b9d835cdc&displaylang=en#filelist

Expected result:
----------------
I except the Mssql extension to load so I can build a connection to a mssql server


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-25 19:49 UTC] kalle@php.net
Try add the path to php to your PATH env. variable, restart your webserver and see if it works. This can be due to ntwdblib.dll (the distributed version) is in the root and the dll will not load if that dependency isn't found.
 [2009-05-26 08:00 UTC] pajoye@php.net
Please ask for support in php-general or php-windows. Also note that the php 5.2 sqlserver extensions do not support the latest SqlServer DLLs but only the one we bundle in the release.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Sep 27 21:05:53 2022 UTC