php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46632 make failure when using configure with --with-mcrypt
Submitted: 2008-11-20 16:57 UTC Modified: 2008-11-20 21:39 UTC
From: ionut dot dumitru at webland dot ro Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.2.6 OS: CentOS release 5.2 (32bit)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ionut dot dumitru at webland dot ro
New email:
PHP Version: OS:

 

 [2008-11-20 16:57 UTC] ionut dot dumitru at webland dot ro
Description:
------------
i encountered a problem when building php 5.2.6 from source. i think this issue is related to a check that is not being made regarding libtool. here is my configure command:

./configure --build=i686-redhat-linux-gnu --host=i686-redhat-linux-gnu --target=i386-redhat-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../config.cache --with-libdir=lib --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d --disable-debug --with-pic --disable-rpath --without-pear --with-bz2 --with-curl --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --without-gdbm --with-gettext --with-gmp --with-iconv --with-jpeg-dir=/usr --with-openssl --with-png --with-pspell --with-expat-dir=/usr --with-pcre-regex=/usr --with-zlib --with-layout=GNU --enable-exif --enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-track-vars --enable-trans-sid --enable-yp --enable-wddx --with-kerberos --enable-ucd-snmp-hack --with-unixODBC=shared,/usr --enable-memory-limit --enable-shmop --enable-calendar --enable-dbx --enable-dio --with-mime-magic=/usr/share/file/magic.mime --without-sqlite --with-libxml-dir=/usr --with-xml --with-system-tzdata --with-apxs2=/usr/sbin/apxs --with-mysql --without-gd --without-odbc --disable-dom --disable-dba --without-unixODBC --disable-pdo --disable-xmlreader --disable-xmlwriter --enable-mbstring --with-mcrypt --with-mysqli

i basically copied the configure command from a php 5.1.6 installation from yum and added a few arguments that i needed, like the --with-mcrypt one. that's why configure reports at the end that it didn't understand some parameters, but that's not the issue. after installing all the packages for which configure has complained, it finished correctly and i was able to run make. but make always ends up with the following error when using --with-mcrypt :

/usr/bin/ld: cannot find -lltdl
collect2: ld returned 1 exit status

after some struggle i managed to do yum install libtool-ltdl-devel and it worked. it may just work with yum install-ltdl probably, but i installed the whole devel package just to be sure. so this looks to me like a problem in the configure script and thought of mentionning it to you if it's of any help.

Ionut


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-20 19:18 UTC] jani@php.net
Problems with bad system installations is not PHP bug. Besides, I 
can't reproduce in same CentOS version.
 [2008-11-20 21:39 UTC] ionut dot dumitru at webland dot ro
the server setup is fine and is made up only of standard packages from centos. the problem in my case is related to libtool-ltdl. are you sure you don't have the libtool-ltdl package installed when you're testing? you might want to try "yum remove libtool-ltdl" before running the configure & make commands
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 17 09:01:26 2020 UTC