php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46619 Installer for Windows binary will add the correct lines for
Submitted: 2008-11-19 17:38 UTC Modified: 2009-01-05 20:51 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: vorlin1975 at gmail dot com Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.6 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: vorlin1975 at gmail dot com
New email:
PHP Version: OS:

 

 [2008-11-19 17:38 UTC] vorlin1975 at gmail dot com
Description:
------------
In using the Windows Installer, all is well, but at the end, the installer adds the correct LoadModule and such but the slashes are backwards as it looks like they were for *nix. Changing to \ allowed PHP to work.

Reproduce code:
---------------
Before:
LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll"

After:
LoadModule php5_module "C:\Program Files\PHP/php5apache2_2.dll"



Expected result:
----------------
Changing that in httpd.conf and restarting Apache, php pages worked fine.

Actual result:
--------------
Same As above.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-19 18:31 UTC] vorlin1975 at gmail dot com
Description:
------------
In using the Windows Installer, all is well, but at the end, the
installer adds the correct LoadModule and such but the slashes are
backwards as it looks like they were for *nix. Changing to \ allowed PHP
to work.

Reproduce code:
---------------
Before:
LoadModule php5_module "C:/Program Files/PHP/php5apache2_2.dll"

After:
LoadModule php5_module "C:\Program Files\PHP\php5apache2_2.dll"

Expected result:
----------------
Changing that in httpd.conf and restarting Apache, php pages worked
fine.

Actual result:
--------------
Same As above.
 [2008-11-19 22:27 UTC] pajoye@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2008-12-03 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2009-01-05 20:51 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 00:05:44 2022 UTC