php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46572 Apache unable to Load php_ldap.dll
Submitted: 2008-11-14 06:23 UTC Modified: 2009-02-23 09:33 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: gdjsmith at gmail dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.2.6 OS: win32 only
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
45 - 14 = ?
Subscribe to this entry?

 
 [2008-11-14 06:23 UTC] gdjsmith at gmail dot com
Description:
------------
My Env is as follows:
Windows Server 2003 Sp2
PHP 5.2.6
Apache 2.0.x

PHP Warning: PHP Startup: Unable to load dynamic library '%PHPRC%\\ext\\php_ldap.dll' - The operating system cannot run %1.\r\n in Unknown on line 0 

The Apache php module will load all of the other libraries except this one.

I've been looking into the ssleay32.dll and libeay32.dll and making sure I have the right ones and that they are in the PATH so the OS can find them.

I've used the MSI and zip versions of PHP but get the same results.
Not sure where else to turn to.

Reproduce code:
---------------
<?php 
$ldapconn =ldap_connect("ldap.test.com", 389); 
if($ldapconn){ 
echo "Success "; 
} 
else{ 
echo "Fail"; 
} 
?> 

Expected result:
----------------
Succss or Fail

Actual result:
--------------
Fatal error: Call to undefined function ldap_connect() 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-14 10:09 UTC] pajoye@php.net
Works here, try to load it using the CLI, to get the exact error message.

 [2008-11-18 17:54 UTC] gdjsmith at gmail dot com
Yes the CLI works it is the apache module that will not load php_ldap.dll.
 [2009-02-23 09:33 UTC] pajoye@php.net
Then be sure that you use the right php.ini or the same PHP (ts or nts). It is not a bug but an install issue.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 03:01:30 2024 UTC