php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46539 SoapClient uses HTTP/1.1 options over HTTP/1.0
Submitted: 2008-11-10 22:01 UTC Modified: 2009-09-03 09:31 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: marques at displague dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.2.6 OS: *
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: marques at displague dot com
New email:
PHP Version: OS:

 

 [2008-11-10 22:01 UTC] marques at displague dot com
Description:
------------
When setting the SoapClient option 'authorization' to SOAP_AUTHENTICATION_DIGEST, the SoapClient connection should attempt to GET with HTTP/1.1 rather than HTTP/1.0 since digest is HTTP/1.1 specific.

I also noticed that the HTTP/1.0 WSDL request issued by the SoapClient class used "Host:" lines.  I may be wrong, but I thought that implied HTTP/1.1. (I don't see it in the HTTP/1.0 RFC).


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-07-23 11:42 UTC] alayn at irontec dot com
Using HTTP/1.0 for the WSDL request against a JAX-WS service, makes PHP freeze until timeout arrives, eventhought it gets the complete response.

Not sure if this is a JAX-WS or PHP related issue, but I think it should be possible to resolve it by performing an HTTP/1.1 request...

A related bug is reported at Java's bug system too:
https://jax-ws.dev.java.net/issues/show_bug.cgi?id=257

It seems they resolved the issue with wget, but I still having the same problem from PHP 5.2.9 :(
 [2009-07-23 13:52 UTC] alayn at irontec dot com
Upssss...

It seems like my bug is more related to:
http://bugs.php.net/bug.php?id=47021

I will try 5.3 as soon as i have time for it.

Sorry :S
 [2009-07-27 12:24 UTC] alayn at irontec dot com
Confirmed. My problem disappeared with 5.3
Sorry again
 [2009-09-03 09:31 UTC] sjoerd@php.net
Thank you for your bug report.

While the usage of digest authentication with HTTP/1.0 may very well be a bug, we have no interest in fixing it in the 5.2 branch. Fixing it would be much work and users can use PHP 5.3 instead if they experience this bug.

The Host header is allowed in HTTP/1.0. The difference with HTTP/1.1 is that it is _required_ in HTTP/1.1.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Dec 05 11:03:34 2021 UTC