php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46413 Weird examples in Unix manual pages
Submitted: 2008-10-29 08:59 UTC Modified: 2008-10-29 11:20 UTC
From: hannes dot magnusson at gmail dot com Assigned: loudi (profile)
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: hannes dot magnusson at gmail dot com
New email:
PHP Version: OS:

 

 [2008-10-29 08:59 UTC] hannes dot magnusson at gmail dot com
Description:
------------
Examples with echo "foo\n"; look weird in the manual output.

I assume \n" has some special meaning in the format as the source seems fine.

Reproduce code:
---------------
pman php_sapi_name

Expected result:
----------------
<?php
$sapi_type = php_sapi_name();
if (substr($sapi_type, 0, 3) == 'cgi') {
    echo "You are using CGI PHP\n";
} else {
    echo "You are not using CGI PHP\n";
}
?>


Actual result:
--------------
<?php
$sapi_type = php_sapi_name();
if (substr($sapi_type, 0, 3) == ?cgi?) {
    echo "You are using CGI PHP0;
} else {
    echo "You are not using CGI PHP0;
}
?>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-29 11:20 UTC] loudi@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 05:05:46 2022 UTC