php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #46404 request for magic method __toNative()
Submitted: 2008-10-27 16:42 UTC Modified: 2017-07-24 21:18 UTC
Votes:4
Avg. Score:4.8 ± 0.4
Reproduced:3 of 3 (100.0%)
Same Version:3 (100.0%)
Same OS:3 (100.0%)
From: info at netmosfera dot it Assigned:
Status: Duplicate Package: *General Issues
PHP Version: 5.2.6 OS: irrelevant
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: info at netmosfera dot it
New email:
PHP Version: OS:

 

 [2008-10-27 16:42 UTC] info at netmosfera dot it
Description:
------------
hello, i'm asking for a new php magic method

__toNative()

useful for 

-a better type hinting
-user defined implementations of native types
-a better way to extend native types without global scope functions
 or class static functions




Reproduce code:
---------------
just a feature request:

http://rafb.net/p/qJ97Gf69.html


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-27 19:15 UTC] info at netmosfera dot it
~same request
http://bugs.php.net/bug.php?id=46128
 [2008-11-23 08:58 UTC] magicaltux@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.


 [2017-07-24 21:18 UTC] colinodell@php.net
-Status: Not a bug +Status: Duplicate -Package: Feature/Change Request +Package: *General Issues
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 00:01:24 2020 UTC