php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46362 Misleading error message in configure script
Submitted: 2008-10-22 08:51 UTC Modified: 2008-10-22 10:59 UTC
From: max at awakers dot com Assigned:
Status: Wont fix Package: Compile Warning
PHP Version: 5.2.6 OS: Centos 5.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: max at awakers dot com
New email:
PHP Version: OS:

 

 [2008-10-22 08:51 UTC] max at awakers dot com
Description:
------------
Refering bug #42907
When supplying bogus parameters to the ./configure script, it reports the following
Notice: Following unknown configure options were used:

This is a bit misleading as some people assume that it was used by the configuration script, while the message states that the user used those invalid parameters.




Reproduce code:
---------------
add any -whatever-param to the config script

Expected result:
----------------
That's a catch-22 because 50% of the users will assume that "used" has the config script as the subject, while the other 50% will assume that it refers to the user.
Let's make it a bit clearer. For example
Notice: The ollowing unknown configure options were supplied but not used:

Actual result:
--------------
Notice: Following unknown configure options were used:

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-22 10:59 UTC] jani@php.net
The text is fine as is.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 06:04:06 2022 UTC