php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46328 Wrong DLL Shipped with windows release PHP 5.2.6
Submitted: 2008-10-17 12:40 UTC Modified: 2008-10-17 12:54 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: elebihan at sarl-roux dot fr Assigned:
Status: Not a bug Package: MSSQL related
PHP Version: 5.2.6 OS: Windows 2000/2003/XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: elebihan at sarl-roux dot fr
New email:
PHP Version: OS:

 

 [2008-10-17 12:40 UTC] elebihan at sarl-roux dot fr
Description:
------------
The underlying DLL ntdwdblib.dll shipped with the release windows PHP 5.2.6 version is very old (1998) and not fonctionnal with most SQL Server (2000/2005).

If a DLL is to be shipped with PHP, it should be a working one (for example 2000.80.194.0 or newer).

If we are supposed to install the DLL by installing the MSSQL Client tool, there should be no included DLL in the PHP Tree.


Reproduce code:
---------------
$result=mssql_connect($ligne['ip'],$ligne['login'],$ligne['pass']);
				

Expected result:
----------------
Connect to the server and return a valid MS-SQL Link resource.

Actual result:
--------------
PHP Warning:  mssql_connect() [<a href='function.mssql-connect'>function.mssql-connect</a>]: Unable to connect to server: xx.xx.xx.xx



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-17 12:47 UTC] pajoye@php.net
We can't update it or use the new versions of the library (legal reasons). Alternatively you can use MS native driver.
 [2008-10-17 12:54 UTC] elebihan at sarl-roux dot fr
If for legal reason the new DLL can't be shipped, the oldest should not. Or at least, not in the default directory, with the name windows is looking for.
Each release of PHP, we have to delete or replace this DLL. 

Please, delete it from Tree subversion, or rename it to .ratherold or something like that to avoid conflict with working version!

It don't want to spend time to convert this old PHP website to native MS SQL.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Dec 06 18:05:53 2022 UTC