php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46278 Unsupported Oracle version! 11.1
Submitted: 2008-10-12 10:40 UTC Modified: 2016-03-08 01:31 UTC
From: Fedora at FamilleCollet dot com Assigned: cjorcl (profile)
Status: Not a bug Package: PDO OCI
PHP Version: 5.2CVS-2008-10-12 (snap) OS: Linux (Fedora 9)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Fedora at FamilleCollet dot com
New email:
PHP Version: OS:

 

 [2008-10-12 10:40 UTC] Fedora at FamilleCollet dot com
Description:
------------
When trying to build against oracle instantclient 11.1.0.6 with

--with-pdo-oci=shared,instantclient,/usr,11.1.0.6

I got the "Unsupported Oracle version! 11.1" error.

Reading the ext/pdo_oci/config.m4

I see 
  PDO_OCI_VERSION="`echo $PDO_OCI_IC_VERS | cut -d. -f1-2`"
which give 11.1

And  
  case $PDO_OCI_VERSION in
    9.x|10.x|11.x)

Probaly  using 
  PDO_OCI_VERSION="`echo $PDO_OCI_IC_VERS | cut -d. -f1`".x

Will give better results ;)

Well and phpinfo still display "PDO Driver for OCI 8 and later" (when 8 is no mor supported).

Reproduce code:
---------------
-

Expected result:
----------------
-

Actual result:
--------------
-

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-12 11:08 UTC] johannes@php.net
Chris, please take a look.
 [2008-10-12 17:55 UTC] sixd@php.net
Stas merged a fix to 5.3 & 6 for this last week.
 [2008-10-16 20:45 UTC] sixd@php.net
This is a doc/user error unrelated to the fix I mentioned.  
With the Instant Client RPMs, use the RPM package version.  This number is used for the path to the files,  I.e. use 11.1.0.1:
  --with-pdo-oci=shared,instantclient,/usr,11.1.0.1

 [2008-10-17 05:40 UTC] Fedora at FamilleCollet dot com
@sixd

I don't understand your comment.

I use the right syntax and path to the lib is detected without any problem.

The issue is during version checking : 11.1 (from line 103) is not 11.x (check in line 137)
 [2016-03-08 01:31 UTC] sixd@php.net
-Package: PDO related +Package: PDO OCI
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Nov 14 20:01:38 2019 UTC