php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #46264 Support FoxPro DBF field types
Submitted: 2008-10-09 09:17 UTC Modified: 2016-11-05 17:03 UTC
Votes:17
Avg. Score:4.6 ± 0.7
Reproduced:15 of 15 (100.0%)
Same Version:9 (60.0%)
Same OS:10 (66.7%)
From: pierre dot beaumadier at gmail dot com Assigned: cmb (profile)
Status: Closed Package: dbase (PECL)
PHP Version: 5.2CVS-2008-10-09 OS: GNU/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pierre dot beaumadier at gmail dot com
New email:
PHP Version: OS:

 

 [2008-10-09 09:17 UTC] pierre dot beaumadier at gmail dot com
Description:
------------
the dbase extension seems to be unable to deal at all a foxpro dbf file.



Reproduce code:
---------------
<?php

$db = dbase_open('table.dbf', 0);

?>


Actual result:
--------------
$ php ./testdbf.php 

Warning: dbase_open(): unable to open database table.dbf in /home/pbeaumadier/testdbf.php on line 3


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-09 09:19 UTC] pierre dot beaumadier at gmail dot com
I can send you an example dbf file if you need, as it seems impossible to attach a file to a bug report
 [2008-10-09 12:19 UTC] pierre dot beaumadier at gmail dot com
For information I tested on this version :

$ php --version
PHP 5.2.4-2ubuntu5.3 with Suhosin-Patch 0.9.6.2 (cli) (built: Jul 23 2008 06:44:49) 
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies


I looked up in the bugs list but didn't see anything related to my problem.

I will try to test the latest snapshot.
 [2008-10-09 12:24 UTC] jani@php.net
Not all fixed bugs are evident in the NEWS. Some people are lazy to write proper descriptions.
 [2008-10-09 13:53 UTC] pierre dot beaumadier at gmail dot com
Same error with the latest snapshot.
 [2009-10-29 12:19 UTC] jmoseby at elasticfabrics dot com
I have this problem too.  It is a major problem for me.  I can provide example dbf files on request.

Running ubuntu hardy 2.6.24-19-generic.

#php --version
PHP 5.2.9-0.dotdeb.2 with Suhosin-Patch 0.9.7 (cli) (built: Apr  7 2009 20:42:41)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
 [2009-11-01 20:28 UTC] sjoerd@php.net
Asked for DBF files per e-mail.
 [2009-11-03 21:16 UTC] sjoerd@php.net
I've put the file Mr Moseby provided online here:
http://www.gissen.nl/files/mach07.DBF
 [2010-02-11 14:26 UTC] jmoseby at elasticfabrics dot com
Bumping this bug:  Has there been any progress made?

Jim
 [2016-07-10 14:05 UTC] cmb@php.net
-Package: dBase related +Package: dbase
 [2016-08-05 15:39 UTC] cmb@php.net
-Summary: FoxPro DBF files can not be opened +Summary: Support FoxPro DBF field types
 [2016-08-05 15:39 UTC] cmb@php.net
Bug #54125 might be a duplicate of this issue.

Anyhow, mach07.DBF contains timestamp ("T") and a _NullFlags ("0")
field, which are not (yet) supported by PECL/dbase.
 [2016-08-05 15:51 UTC] cmb@php.net
-Type: Bug +Type: Feature/Change Request
 [2016-11-05 17:02 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-11-05 17:02 UTC] cmb@php.net
At least timestamp ("T") and nullable fields will be supported as of
dbase 7.0.0, so I'm closing this ticket.
 [2016-11-05 17:03 UTC] cmb@php.net
Furthermore, the first unsupported field type in the DBF will be
explicitly reported.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 08:01:26 2020 UTC