php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46235 Series of OS alerts
Submitted: 2008-10-05 09:46 UTC Modified: 2008-10-05 10:18 UTC
From: madhusar at yahoo dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 5.2.6 OS: Windows 2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: madhusar at yahoo dot com
New email:
PHP Version: OS:

 

 [2008-10-05 09:46 UTC] madhusar at yahoo dot com
Description:
------------
Tried a sample program (from the PHP manual) with Apache 2.0.63 and PHP 5.2.6 installed.  
Got a OS alert.  
Title of the alert box "php-win.exe - Unable to locate DLL"

Contents of the alert box 
"The dynamic link library OCI.dll could not be found in the specified path ...<seemed like the Windows path variable expansion>"

Subsequently, same alert boxes came for
LIBPQ.dll
sqlite3.dll
aspell-15.dll
libcs.dll
DB2cli.dll
isqltoqa.dll

and so on.  The .php file was not rendered finally.

Reproduce code:
---------------
<html>
    <head>
        <title>Example</title>
    </head>
    <body>

        <?php 
        echo "Hi, I'm a PHP script!"; 
        ?>

    </body>
</html> 

Expected result:
----------------
A browser window with a title "Example"

and contents as follows.

Hi, I'm a PHP script!

Actual result:
--------------
A series of windows alerts 
Alert box title : php-win.exe - Unable to locate DLL
Alert box contents :
The dynamic link library OCI.dll could not be found in the specified path ... <looked like the windows PATH variable is expanded here>

Other DLLs not found are
LIBPQ.dll
sqlite3.dll
aspell-15.dll
libcs.dll
DB2cli.dll
isqltoqa.dll
iilibapi.dll
libSQLDBC_C.dll
lcrzo.dll

etc.,

None of these DLLs are found in the system.  

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-05 10:18 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Please get installation support.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 14:01:28 2024 UTC