php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46014 Unable to change Configuration File Path
Submitted: 2008-09-07 03:43 UTC Modified: 2008-09-07 11:23 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: php at perfectory dot com dot au Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.6 OS: Windows 2003 R2 x64
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: php at perfectory dot com dot au
New email:
PHP Version: OS:

 

 [2008-09-07 03:43 UTC] php at perfectory dot com dot au
Description:
------------
I have manually installed PHP 5.2.6 on my Win2k3 box at C:\PHP and can not seem to change the Configuration Path File variable. I have added the registry key IniFilePath = C:\PHP at HKLM\SOFTWARE\PHP and HKLM\SOFTWARE\PHP\5.2.6 and added C:\PHP to the PATH variable.

Setup: IIS6 with ISAPI. As I have a 64 bit OS, I have enabled IIS to run both 32bit and 64bit applications. If I move the php.ini and all non-php dlls to C:\WINDOWS it works, but I want to store this in my PHP directory.

Reproduce code:
---------------
<?php
phpinfo();
?>

Expected result:
----------------
Configuration File (php.ini) Path to be set to C:\PHP and Loaded Configuration File to be C:\PHP\php.ini

Actual result:
--------------
Configuration File (php.ini) Path is set to C:\WINDOWS and Loaded Configuration File is set to (none).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-09-07 11:23 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 12 00:03:34 2022 UTC