php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45985 touch() opened file
Submitted: 2008-09-03 16:52 UTC Modified: 2008-09-04 08:24 UTC
From: david at grudl dot com Assigned: pajoye (profile)
Status: Closed Package: Filesystem function related
PHP Version: 5.3.0alpha2 OS: Windows XP SP3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: david at grudl dot com
New email:
PHP Version: OS:

 

 [2008-09-03 16:52 UTC] david at grudl dot com
Description:
------------
Opened file can be touched in Windows succefully, but under PHP 5.3 alpha 2 it generates error message 'Utime failed'. I think error is caused by new function win32_utime() in tsrm_virtual_cwd.c called from virtual_utime().



Reproduce code:
---------------
$f = fopen('test.dat', 'r');
touch('test.dat');
fclose($f);

Expected result:
----------------
modification time of file test.dat is updated

Actual result:
--------------
Warning: touch(): Utime failed: Bad file descriptor

or

Warning: touch(): Utime failed: No such file or directory

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-09-04 08:24 UTC] pajoye@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 01:03:53 2023 UTC