php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45949 Why 0(int, NOT '0'- string) in any string array?
Submitted: 2008-08-29 16:26 UTC Modified: 2008-08-29 16:36 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: pengxin at itsail dot com Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 5.2.6 OS: WinXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pengxin at itsail dot com
New email:
PHP Version: OS:

 

 [2008-08-29 16:26 UTC] pengxin at itsail dot com
Description:
------------
Well. why 0(it's int, NOT '0' with string) in any string array? I think it shouldn't be.

Reproduce code:
---------------
<?php
if (in_array(0, array('All'))) {
	echo 'a';
} else {
	echo 'b';
}
?>

Expected result:
----------------
it outputs "b", and I think it should be "a". Because 0 and "0" are different.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-29 16:36 UTC] felipe@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Use the third parameter.

http://docs.php.net/in-array
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 08:01:26 2020 UTC