php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45874 socket_read does not work
Submitted: 2008-08-20 20:01 UTC Modified: 2008-08-29 01:00 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: roberto at spadim dot com dot br Assigned:
Status: No Feedback Package: Sockets related
PHP Version: 5.2.6 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roberto at spadim dot com dot br
New email:
PHP Version: OS:

 

 [2008-08-20 20:01 UTC] roberto at spadim dot com dot br
Description:
------------
i can't read from socket (socket_read) with some ./configure options, but with other ./configure options the socket_Read work
i will send the wrong one, and the right one


Reproduce code:
---------------
socket_read don't work with the first and work with the second

Expected result:
----------------
work with first and second configurations


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-20 20:03 UTC] roberto at spadim dot com dot br
this work:
        phpconfig="--prefix=/usr \
        --sysconfdir=/etc \
        --with-layout=PHP \
        --with-ttf \
        --enable-mailparse \
        --with-config-file-scan-dir=/etc \
        --enable-bcmath=shared \
        --enable-ftp=shared \
        --enable-gd-native-ttf \
        --enable-magic-quotes \
        --enable-posix=shared \
        --enable-session \
        --enable-shared \
        --enable-shmop=shared \
        --enable-pdo=shared \
        --enable-sqlite-utf8 \
        --enable-sockets=shared \
        --enable-xml \
        --enable-sysvsem=shared \
        --enable-sysvshm=shared \
        --enable-sysvmsg=shared \
        --enable-track-vars \
        --enable-safe-mode \
        --with-readline \
        --with-bz2=shared \
        --with-curl \
        --with-mime-magic \
        --with-freetype-dir=/usr \
        --with-gd=shared \
        --enable-exif \
        --with-jpeg-dir=/usr \
        --enable-dba \
        --without-db2 \
        --without-db3 \
        --with-inifile \
        --with-flatfile \
        --with-gdbm \
        --with-openssl \
        --with-gettext \
        --with-ldap=shared \
        --with-mcrypt=shared,/usr \
        --with-mysql-sock=/tmp/mysql.sock \
        --with-pdo-mysql=shared,/usr \
        --with-mysql=shared,/usr \
        --with-sqlite=shared \
        --with-pdo-sqlite=shared,/usr \
        --with-pear=/usr/share/pear \
        --with-dom \
        --with-dom-xslt \
        --with-xsl \
        --with-png-dir=/usr \
        --with-regex=php \
        --with-zlib \
        --enable-soap=shared \
        --enable-mbstring=all \
        --enable-mbregex \
        --with-snmp=shared,/usr \
        --enable-dbase \
        --enable-pcntl"

	
        ./configure ${phpconfig} \
                --disable-cgi \
                --with-readline \
                --enable-pcntl \
                --with-pear=/usr/share/pear
 [2008-08-20 20:04 UTC] roberto at spadim dot com dot br
this don't work:
        phpconfig="--prefix=/usr \
        --sysconfdir=/etc/php \
        --with-layout=GNU \
        --with-config-file-path=/etc/php \
        --with-config-file-scan-dir=/etc/php/conf.d \
        --enable-inline-optimization \
        --disable-debug \
        --disable-rpath \
        --disable-static \
        --enable-shared \
        "

	
	
        phpextensions="--with-openssl=shared \
        --with-zlib=shared \
        --enable-bcmath=shared \
        --with-bz2=shared \
        --with-curl=shared \
        --enable-dba=shared \
        --without-db2 \
        --without-db3 \
        --with-db4=shared \
        --with-gdbm=shared \
        --enable-dbase=shared \
        --enable-exif=shared \
        --enable-ftp=shared \
        --with-gd=shared \
        --enable-gd-native-ttf \
        --with-jpeg-dir=shared,/usr \
        --with-png-dir=shared,/usr \
        --with-gettext=shared \
        --with-ldap=shared \
        --with-mcrypt=shared \
        --with-mysql=shared \
        --with-mysql-sock=/tmp/mysql.sock \
        --with-mysql=shared \
        --with-mysqli=shared \
        --with-ncurses=shared \
        --enable-pdo=shared \
        --with-pdo-mysql=shared \
        --with-pdo-sqlite=shared \
        --with-sqlite=shared \
        --enable-shmop=shared \
        --with-snmp=shared \
        --enable-soap=shared \
        --enable-sqlite-utf8=shared \
        --enable-sysvmsg=shared \
        --enable-sysvsem=shared \
        --enable-sysvshm=shared \
        --with-tidy=shared \
        --with-xsl=shared \
        --enable-zip=shared \
        --enable-posix=shared \
        --enable-sockets=shared \
        --enable-xml \
        --with-ttf=shared \
        --enable-session=shared \
        --with-regex=php \
        --with-pcre-regex=/usr \
        --enable-json=shared \
        --with-iconv=shared \
        --with-xmlrpc=shared \
        --with-pspell=shared \
        --with-freetype-dir=shared,/usr \
        "

	
        ./configure ${phpconfig} \
                --disable-cgi \
                --with-readline \
                --enable-pcntl \
                --with-pear=/usr/share/pear \
                ${phpextensions}
 [2008-08-20 20:05 UTC] roberto at spadim dot com dot br
linux: archlinux 
the source compile ok without error
binary work ok without segmentation fault
just socket dont' work
 [2008-08-21 20:52 UTC] jani@php.net
What exactly is the difference with the configure options? (no, I'm not going to go over line by line those..) 

Reduce the options to minimum amount which shows the error.
 [2008-08-22 03:02 UTC] roberto at spadim dot com dot br
the working is diferent here:

--with-layout=PHP 
--with-ttf 
--enable-mailparse 
--enable-magic-quotes  
--enable-session  
--enable-sqlite-utf8  
--enable-track-vars 
--enable-safe-mode  
--with-curl 
--with-mime-magic 
--with-freetype-dir=/usr 
--enable-exif 
--with-jpeg-dir=/usr 
--enable-dba 
--without-db2 
--without-db3 
--with-inifile 
--with-flatfile 
--with-gdbm 
--with-openssl 
--with-gettext 
--with-mcrypt=shared,/usr 
--with-mysql-sock=/tmp/mysql.sock 
--with-pdo-mysql=shared,/usr 
--with-mysql=shared,/usr 
--with-sqlite=shared 
--with-pdo-sqlite=shared,/usr 
--with-dom 
--with-dom-xslt 
--with-xsl 
--with-png-dir=/usr 
--with-zlib 
--enable-mbstring=all 
--enable-mbregex 
--enable-dbase  
--with-readline 



the other is differnt here:

--with-layout=GNU 
--enable-inline-optimization 
--disable-debug 
--disable-rpath 
--disable-static  
--with-openssl=shared 
--with-zlib=shared 
--with-curl=shared 
--enable-dba=shared 
--without-db2 
--without-db3 
--with-db4=shared 
--with-gdbm=shared 
--enable-dbase=shared 
--enable-exif=shared 
--with-jpeg-dir=shared,/usr 
--with-png-dir=shared,/usr 
--with-gettext=shared 
--with-ldap=shared 
--with-mcrypt=shared 
--with-mysql=shared 
--with-mysql-sock=/tmp/mysql.sock 
--with-mysql=shared 
--with-mysqli=shared 
--with-ncurses=shared 
--with-pdo-mysql=shared 
--with-pdo-sqlite=shared 
--with-sqlite=shared 
--with-snmp=shared 
--enable-sqlite-utf8=shared 
--with-tidy=shared 
--with-xsl=shared 
--enable-zip=shared   
--with-ttf=shared 
--enable-session=shared 
--with-pcre-regex=/usr 
--enable-json=shared 
--with-iconv=shared 
--with-xmlrpc=shared 
--with-pspell=shared 
--with-freetype-dir=shared,/usr
   



:) sorry i just found and sent, the server is in production
 [2008-08-22 03:07 UTC] roberto at spadim dot com dot br
i had a problem like this last year, the working ./configure script worked for a old server, that's because i could change and get the php socket working again, i readed (i don't remember where) that openssl was causing some problems with socket, since i don't use openssl i set this always on
i don't know if this is a problem, but maybe... the --enable-inline-optimization, the --with-layout=GNU, --disable-debug , --disable-rpath, --disable-static, should be a problem too, i didn't tested but i think that's where we should start testing, 
i don't have (yet) another server to test this configuration options, i will find a new server and test it maybe next month
thanks
 [2008-08-29 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Dec 04 06:05:52 2022 UTC