php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45836 cannot use com
Submitted: 2008-08-16 23:55 UTC Modified: 2015-04-07 17:54 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: keichee at gmail dot com Assigned:
Status: Not a bug Package: COM related
PHP Version: 6CVS-2008-08-16 (snap) OS: windows xp sp3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: keichee at gmail dot com
New email:
PHP Version: OS:

 

 [2008-08-16 23:55 UTC] keichee at gmail dot com
Description:
------------
i cannot use com, it have error:
PHP Fatal error:  Call to undefined method com::Navigate2()
it works on php5 snaps though, but i want to work in php6


Reproduce code:
---------------
$ie = new COM("InternetExplorer.Application");
$ie->Visible = true;
$ie->Navigate2($url);

Expected result:
----------------
the ie will open and navigate to the said url

Actual result:
--------------
PHP Fatal error:  Call to undefined method com::Navigate2()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-17 00:00 UTC] keichee at gmail dot com
changed the category to com related
 [2015-04-07 17:54 UTC] cmb@php.net
-Status: Open +Status: Not a bug
 [2015-04-07 17:54 UTC] cmb@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 16:03:56 2022 UTC