php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45815 Illegal stub for phar
Submitted: 2008-08-13 23:50 UTC Modified: 2008-08-18 20:32 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: felipensp at gmail dot com Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.3CVS-2008-08-13 (CVS) OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: felipensp at gmail dot com
New email:
PHP Version: OS:

 

 [2008-08-13 23:50 UTC] felipensp at gmail dot com
Description:
------------
In the end of compilation:

Generating phar.php
Generating phar.phar
pear: not found
Pear package PHP_Archive or Archive.php class file not found.

Fatal error: Uncaught exception 'PharException' with 
message 'illegal stub for 
phar "/usr/home/felipe/php5/ext/phar/phar.phar"' 
in /usr/home/felipe/php5/ext/phar/phar.php:994
Stack trace:
#0 /usr/home/felipe/php5/ext/phar/phar.php(994): 
Phar->setStub('#!/usr/local/bi...')
#1 /usr/home/felipe/php5/ext/phar/phar.php(1054): 
PharCommand->phar_set_stub_begin(Object(Phar), '/usr/home/felip...', '/usr/home/felip...', '/usr/local/bin/...')
#2 [internal function]: PharCommand->cli_cmd_run_pack(Array)
#3 /usr/home/felipe/php5/ext/phar/phar.php(225): 
call_user_func(Array, Array)
#4 /usr/home/felipe/php5/ext/phar/phar.php(2073): 
CLICommand->__construct(19, Array)
#5 {main}
  thrown in /usr/home/felipe/php5/ext/phar/phar.php on line 994
*** Error code 255

Stop in /usr/home/felipe/php5.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-14 17:43 UTC] jani@php.net
Assigned to the PHAR maintainer.
 [2008-08-18 20:32 UTC] cellog@php.net
valid bug, but duplicate of Bug #45726
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 17:01:23 2020 UTC