php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #458 odbc_result() with the MS Access field type memo returns it incorrectly
Submitted: 1998-06-13 13:33 UTC Modified: 1998-06-24 10:56 UTC
From: andi at vipe dot technion dot ac dot il Assigned:
Status: Closed Package: ODBC related
PHP Version: 3.0 Final Release OS: Windows 95
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andi at vipe dot technion dot ac dot il
New email:
PHP Version: OS:

 

 [1998-06-13 13:33 UTC] andi at vipe dot technion dot ac dot il
The PHP 3.0 precompiled version.
All data retreived from an MS Access database with field type memo is ALWAYS
returned with a trailing 1. Changing the field to text fixes the problem. Thus it's probably some
kind of off by one bug or something when returning fields of type memo.
Please whoever is into the ODBC stuff take a look at it. Maybe you're not using the sqlgetdata()
function correctly or something like that.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-06-24 10:56 UTC] kara
I can't reproduce this behaviour on Linux/Adabas. A similar problem was
reported and supposed to be fixed for the later RCs.
Could be a misbehaving ODBC driver ?
Was the "passthrou behaviour". Changed defaults for 3.01
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 07:01:23 2020 UTC