php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4577 Apache 1.3.12 httpd dies immediately after startup
Submitted: 2000-05-24 15:38 UTC Modified: 2000-05-30 19:30 UTC
From: scheller at spamcop dot net Assigned:
Status: Closed Package: Oracle related
PHP Version: 4.0.0 Release OS: RedHat 6.2 2.2.14-5.0 i686
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: scheller at spamcop dot net
New email:
PHP Version: OS:

 

 [2000-05-24 15:38 UTC] scheller at spamcop dot net
Using Oracle 8.1.5 (downloaded from Oracle technet); oracle environment set to locally installed database, using this configure line:

./configure --with-apxs=/usr/sbin/apxs --with-oracle

After successful make & make install and adding $ORACLE_HOME/lib to my /etc/ld.so.conf so the php4 module could find the shared Oracle libraries, any time I try to start the httpd (Apache 1.3.12/stock from RH 6.2 distribution) it dies somewhere in the init process before even writing anything to the error_log.  Using strace, determined that httpd did successfully fork its children and then ???

php.ini file is stock from installation.

Remade php4 without Oracle and all is fine.

Can anyone give me more information about how to get more as to what's happening?  Where httpd is dying?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-05-30 19:30 UTC] scheller at spamcop dot net
Had to create new httpd executable with the -lpthread option on the link line.  Now all is well.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Jul 29 03:01:28 2021 UTC