php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45739 what is this for?
Submitted: 2008-08-07 03:55 UTC Modified: 2008-08-07 07:27 UTC
From: zhangguiyin at gmail dot com Assigned:
Status: Not a bug Package: Regexps related
PHP Version: 5.2.6 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: zhangguiyin at gmail dot com
New email:
PHP Version: OS:

 

 [2008-08-07 03:55 UTC] zhangguiyin at gmail dot com
Description:
------------
array preg_grep ( string pattern, array input [, int flags] )

it wont work when array input is a Multi-dimensional array

Reproduce code:
---------------
array preg_grep ( string pattern, array input [, int flags] )

it wont work when array input is a Multi-dimensional array



Expected result:
----------------
array(1) { [2]=> string(3) "cpu" } 


Actual result:
--------------
array(0) { } 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-07 03:57 UTC] zhangguiyin at gmail dot com
The following is the examplt code
<?php
$tables = array(array("eth3", "eth4"), array( "cpu", "cpu1"), "con", "new_con");
$name = "cpu";
$is_exist = preg_grep( "/^$name$/", $tables ); 
var_dump($is_exist); 
?>
 [2008-08-07 07:27 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 14:01:28 2024 UTC