php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45738 php stream error
Submitted: 2008-08-07 01:21 UTC Modified: 2008-08-07 07:27 UTC
From: ajai73 at hotmail dot com Assigned:
Status: Not a bug Package: Streams related
PHP Version: 4.4.8 OS: vista 32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ajai73 at hotmail dot com
New email:
PHP Version: OS:

 

 [2008-08-07 01:21 UTC] ajai73 at hotmail dot com
Description:
------------
i have an error when loading csv widget on my site. 
-partial widget
-navbar not show

Error state.
Warning: fopen(/path_to/uploads/content.csv) [function.fopen]: failed to open stream: No such file or directory in /mnt/w0500/d41/s13/b02e8f66/www/lnaelite.org/widget/libs/Content.php on line 6

Warning: fgetcsv(): supplied argument is not a valid stream resource in /mnt/w0500/d41/s13/b02e8f66/www/lnaelite.org/widget/libs/Content.php on line 7

Warning: fclose(): supplied argument is not a valid stream resource in /mnt/w0500/d41/s13/b02e8f66/www/lnaelite.org/widget/libs/Content.php on line 18








Reproduce code:
---------------
<?

	function getCsv($parse) {
	
		$i = 0;
		$handle = fopen ($parse,"r");
		while($data = fgetcsv ($handle, 1000, ",")) {
			if ($i == 0) { 
			$key_arr = $data; 
			}
			reset($key_arr);
			while(list($index,$name) = each($key_arr)) { 
				$temp_arr[$name] = $data[$index]; 
			}
			$result[$i] = $temp_arr;
			$i++;
		}
		fclose ($handle);
	
		return $result;
	}


Expected result:
----------------
no database required for widget.
ftp widget files to writable dir/. 
(use excel docs. 
widget appears fully functional.



Actual result:
--------------
widget functional with basketball stats.
roster. images. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-07 07:27 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Oct 19 10:01:26 2019 UTC